Cant get any of my data from my iphone 4 to my new iphone 6, Help!, what did I do wrong?

So, today I bought the iphone 6 replacing my old iphone4. I buy the IP6 and the guy at the store immediately takes the sim card out of my IP4 and puts in it my new one. I havent done any backing up or Icloud stuff ever on my 4 cuz I have no idea how it works n stuff. So nothing on my iphone 4 is backed up (contacts, pics, music, etc, watsapp chats) I just noticed that now because I cant get any data on my new phone. So in the shop we do the normal set up procedure (language, etc). Then an option came up, something like "retrieve from itunes" or "retrieve from cloud" and another option. I did the itunes option, and it didnt allow me, so I chose the cloud function. That was that, and I went home. At home I started checking stuff. contacts were all my OLD contacts and NONE of the NEW ones. My camera roll was from AGES ago, none of my new photos. None of my apps appeared on my new phone that were on the IP4. On watsapp, all the old chats were there, and some new ones but those new chats history start at the very beggining of the time it was made and all I can see now is it saying "you have been added to the chat". I couldnt get into my music library on my phone in the beginning, but then I happend to install the 9.2 software on my iphone6, and then I got in. So I ended up sending myself all the new contacts in my contacts list and saving them to my contacts. What do I do?? I also reinstalled all the apps I had on my old phone manually. :( HELP wat do I do to get it back?? Also, I started going into my watsapp on my old Iphone 4 and it required my number. So I gave that in and it sent me a code, and it also said this number is on another device. Then I also tried icloud back up and watsapp chat back up , I dont know if anything happend. I tried getting into both phones with my number back and forth to see if I could fix something, and then at some point it wouldnt let me put my number into my old phone anymore,saying,i have to wait 3 hours,and then I can try again
Asked Jan 12, 2016

TIP: If it's not your answer to this question, please click "Leave a Comment" button under the question to communicate with the question owner.