My disney xd channel changed Language to turkey not english.im from serbia.

Help my DXD Changed Language
stefan99aee
Asked Sep 09, 2011

If you are looking for a place to share your travel photos and stories, then try BigRoom.

In Internet Explorer, go to Tools>Internet Options and click on Languages at the bottom. If English is an option in the list, select it.

I'm not sure this will take care of the problem. Disney doesn't provide support information on their web site that I can find.
Rob
Answered Sep 09, 2011

TIP: If it's not your answer to this question, please click "Leave a Comment" button under the question to communicate with the question owner.

Categories