Bladez Metal Chopper will not charge

When Charging my chopper from the remote it works fine alhough the flying time is reduced since the first time. Suspect the batteries I have in now are not of as high a quality as the first set.
So I try the USB charger. When inserted in the chopper, a little red light turns on in the USB itsefl. When inserted in a Powersource, be that from a computer or a AC Charger with USB, the red light turns of. However the chopper does not seem to charge.
Any suggestions as to what my problem is?
ole
Asked Mar 12, 2011
The red light indicates that it's charging. A green light says it's done but a USB device has power limits depending on the power supply of the computer. If the batteries that you're using are different than the original ones, see if you can find someone who has a charger that doesn't go through a computer. If they will charge on that charger and not on the computer, I would suspect you may be exceeding the power supply limits of the USB.
Rob
Answered Mar 12, 2011
trouble is the red light is on when the cord is only in the chopper. when I connect it to a charger the red light turns of. No green light appears after time and the chopper does not charge. I have tried it in a charger directly from a power outlet compattible with USB, but the case is the same.
ole Mar 13, 2011
The only thing I could find on a search that might be (but probable isn't) related to your issue is the statement below. Check the rechargeable batteries to see if there's any difference in them than the originals. It sounds like there's something uncompatable between the device and the batteries. If the originals worked OK, it's likely the batteries.

"ON THAT CHARGER, per Instructions*, you FIRST plug both charge plugs into your USB, THEN plug to copter. After charging, unplug the USB plugs BEFORE de-plugging the copter."

Read more: http://3chrchelicopters.proboards.com/index.cgi?board=new&action=display&thread=9#ixzz1GUDxT1iT
Rob Mar 13, 2011
Im sorry to hear you guys are having problems with your helicopters. If you need any help with repairing any of your Bladez helicopters you can contact me directly and I will be able to help you. Also if you need spares you can visit our website BladezToyz.co.uk for a very wide range of spares.

My email address is [email protected]
Contact Number: 02392 658 255
BladezToyz
Answered Jan 06, 2012
Im having an issue w my helicopter too. I just received a new one in the mail that came w a usb charger. I tried to charge my old heli w the usb charger for the new heli (same sized heli) to save batteries. anyway after I tried to charge it w the usb the heli no longer takes a charge from its original control/charger that was working fine up until I tried the new usb.which by the way never charged the heli.(big mistake) I believe you have having the same issues I am. I believe the batteries on the heli are not the issue, I think it has to do w using a dif charger and overloading something. Im still trying to get this thing fixed. I will let you guys know If I figure it out.
DmanRC
Answered Aug 21, 2012

TIP: If it's not your answer to this question, please click "Leave a Comment" button under the question to communicate with the question owner.

Categories